Mac下Anaconda Navigator打不开的解决办法

/ 默认分类 / 没有评论 / 133浏览

现象

点击 Anaconda-navigator 的图标后,图表会出现几秒(initializing),然后就退出

升级版本

打开终端,输入指令: sudo conda update conda


maruifu@maruifudeMacBook-Pro ~ % sudo conda update conda
Password:
Channels:
 - defaults
Platform: osx-64
Collecting package metadata (repodata.json): done
Solving environment: done

## Package Plan ##

  environment location: /opt/anaconda3

  added / updated specs:
    - conda


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    archspec-0.2.3             |     pyhd3eb1b0_0          47 KB
    ca-certificates-2024.3.11  |       hecd8cb5_0         128 KB
    conda-24.3.0               |  py311hecd8cb5_0         1.2 MB
    ------------------------------------------------------------
                                           Total:         1.4 MB

The following packages will be UPDATED:

  archspec                               0.2.1-pyhd3eb1b0_0 --> 0.2.3-pyhd3eb1b0_0 
  ca-certificates                     2023.12.12-hecd8cb5_0 --> 2024.3.11-hecd8cb5_0 
  conda                              24.1.2-py311hecd8cb5_0 --> 24.3.0-py311hecd8cb5_0 


Proceed ([y]/n)? y


Downloading and Extracting Packages:
                                                                                
Preparing transaction: done                                                     
Verifying transaction: done                                                     
Executing transaction: done

等待安装,输入指令

sudo conda update --all

maruifu@maruifudeMacBook-Pro ~ % sudo conda update --all
Channels:
 - defaults
Platform: osx-64
Collecting package metadata (repodata.json): done
Solving environment: done

## Package Plan ##

  environment location: /opt/anaconda3


The following packages will be downloaded:

    package                    |            build
    ---------------------------|-----------------
    anaconda-anon-usage-0.4.4  |py311hfb7c958_100          30 KB
    anaconda-cloud-auth-0.5.0  |  py311hecd8cb5_0          51 KB
    anaconda-navigator-2.5.4   |  py311hecd8cb5_1         7.5 MB
    annotated-types-0.6.0      |  py311hecd8cb5_0          27 KB
    autopep8-2.0.4             |     pyhd3eb1b0_0          44 KB
    black-24.3.0               |  py311hecd8cb5_0         376 KB
    bokeh-3.4.0                |  py311h85bffb1_1         5.9 MB
    bzip2-1.0.8                |       h6c40b1e_5         151 KB
    colorcet-3.1.0             |  py311hecd8cb5_0         614 KB
    comm-0.2.1                 |  py311hecd8cb5_0          18 KB
    conda-build-24.3.0         |  py311hecd8cb5_0         785 KB
    conda-pack-0.7.1           |  py311hecd8cb5_0          69 KB
    conda-repo-cli-1.0.88      |  py311hecd8cb5_0         186 KB
    cookiecutter-2.6.0         |  py311hecd8cb5_0         143 KB
    cryptography-42.0.5        |  py311h30e54ef_0         1.3 MB
    flake8-7.0.0               |  py311hecd8cb5_0         120 KB
    ipywidgets-8.1.2           |  py311hecd8cb5_0         259 KB
    jsonpatch-1.33             |  py311hecd8cb5_0          37 KB
    jupyterlab_widgets-3.0.10  |  py311hecd8cb5_0         196 KB
    keyring-24.3.1             |  py311hecd8cb5_0          82 KB
    lazy-object-proxy-1.10.0   |  py311h6c40b1e_0          37 KB
    libmamba-1.5.8             |       h258a794_1         1.4 MB
    libmambapy-1.5.8           |  py311h8c3233a_1         281 KB
    numba-0.59.1               |  py311hdb55bb0_0         5.8 MB
    packaging-23.2             |  py311hecd8cb5_0         174 KB
    panel-1.4.1                |  py311hecd8cb5_0        18.6 MB
    param-2.1.0                |  py311hecd8cb5_0         269 KB
    plotly-5.19.0              |  py311h85bffb1_0         6.2 MB
    pycodestyle-2.11.1         |  py311hecd8cb5_0          72 KB
    pydantic-2.5.3             |  py311hecd8cb5_0         721 KB
    pydantic-core-2.14.6       |  py311hf2ad997_0         1.6 MB
    pydeck-0.7.1               |  py311hecd8cb5_0         1.6 MB
    pyflakes-3.2.0             |  py311hecd8cb5_0         156 KB
    pylint-venv-3.0.3          |  py311hecd8cb5_0          14 KB
    pympler-0.9                |             py_0         160 KB
    pyobjc-core-10.1           |  py311h46256e1_0         501 KB
    pyobjc-framework-cocoa-10.1|  py311h9205ec4_0         396 KB
    pyobjc-framework-coreservices-10.1|  py311h46256e1_0          67 KB
    pyobjc-framework-fsevents-10.1|  py311hecd8cb5_0          16 KB
    python-lsp-black-2.0.0     |  py311hecd8cb5_0          18 KB
    python-lsp-jsonrpc-1.1.2   |     pyhd3eb1b0_0          12 KB
    python-lsp-server-1.10.0   |  py311hecd8cb5_0         159 KB
    pyviz_comms-3.0.2          |  py311hecd8cb5_0          57 KB
    qdarkstyle-3.2.3           |     pyhd3eb1b0_0         615 KB
    qtconsole-5.5.1            |  py311hecd8cb5_0         259 KB
    rope-1.12.0                |  py311hecd8cb5_0         591 KB
    scipy-1.12.0               |  py311h7695dc5_0        23.7 MB
    scrapy-2.11.1              |  py311hecd8cb5_0         847 KB
    semver-3.0.2               |  py311hecd8cb5_0          46 KB
    spyder-5.5.1               |  py311hecd8cb5_0        11.0 MB
    spyder-kernels-2.5.0       |  py311hecd8cb5_0         209 KB
    streamlit-1.16.0           |  py311hecd8cb5_0         6.9 MB
    tomli-2.0.1                |  py311hecd8cb5_0          31 KB
    tzdata-2024a               |       h04d1e81_0         116 KB
    widgetsnbextension-4.0.10  |  py311hecd8cb5_0         948 KB
    xz-5.4.6                   |       h6c40b1e_0         373 KB
    yapf-0.40.2                |  py311hecd8cb5_0         474 KB
    ------------------------------------------------------------
                                           Total:       102.0 MB

The following NEW packages will be INSTALLED:

  annotated-types    pkgs/main/osx-64::annotated-types-0.6.0-py311hecd8cb5_0 
  pydantic-core      pkgs/main/osx-64::pydantic-core-2.14.6-py311hf2ad997_0 
  pympler            pkgs/main/noarch::pympler-0.9-py_0 
  tomli              pkgs/main/osx-64::tomli-2.0.1-py311hecd8cb5_0 

The following packages will be UPDATED:

  anaconda-anon-usa~                0.4.3-py311hfb7c958_100 --> 0.4.4-py311hfb7c958_100 
  anaconda-cloud-au~                  0.1.4-py311hecd8cb5_0 --> 0.5.0-py311hecd8cb5_0 
  anaconda-navigator                  2.5.3-py311hecd8cb5_0 --> 2.5.4-py311hecd8cb5_1 
  autopep8                               1.6.0-pyhd3eb1b0_1 --> 2.0.4-pyhd3eb1b0_0 
  black                             23.11.0-py311hecd8cb5_0 --> 24.3.0-py311hecd8cb5_0 
  bokeh                               3.3.4-py311h85bffb1_0 --> 3.4.0-py311h85bffb1_1 
  bzip2                                    1.0.8-h1de35cc_0 --> 1.0.8-h6c40b1e_5 
  colorcet                            3.0.1-py311hecd8cb5_0 --> 3.1.0-py311hecd8cb5_0 
  comm                                0.1.2-py311hecd8cb5_0 --> 0.2.1-py311hecd8cb5_0 
  conda-build                        24.1.2-py311hecd8cb5_0 --> 24.3.0-py311hecd8cb5_0 
  conda-pack         pkgs/main/noarch::conda-pack-0.6.0-py~ --> pkgs/main/osx-64::conda-pack-0.7.1-py311hecd8cb5_0 
  conda-repo-cli                     1.0.75-py311hecd8cb5_0 --> 1.0.88-py311hecd8cb5_0 
  cookiecutter                        2.5.0-py311hecd8cb5_0 --> 2.6.0-py311hecd8cb5_0 
  cryptography                       42.0.2-py311h30e54ef_0 --> 42.0.5-py311h30e54ef_0 
  flake8                              6.0.0-py311hecd8cb5_0 --> 7.0.0-py311hecd8cb5_0 
  ipywidgets         pkgs/main/noarch::ipywidgets-7.6.5-py~ --> pkgs/main/osx-64::ipywidgets-8.1.2-py311hecd8cb5_0 
  jsonpatch          pkgs/main/noarch::jsonpatch-1.32-pyhd~ --> pkgs/main/osx-64::jsonpatch-1.33-py311hecd8cb5_0 
  jupyterlab_widgets                  3.0.9-py311hecd8cb5_0 --> 3.0.10-py311hecd8cb5_0 
  keyring                           23.13.1-py311hecd8cb5_0 --> 24.3.1-py311hecd8cb5_0 
  lazy-object-proxy                   1.6.0-py311h6c40b1e_0 --> 1.10.0-py311h6c40b1e_0 
  libmamba                                 1.5.6-h63cd6dc_0 --> 1.5.8-h258a794_1 
  libmambapy                          1.5.6-py311h8c3233a_0 --> 1.5.8-py311h8c3233a_1 
  numba                              0.59.0-py311hdb55bb0_0 --> 0.59.1-py311hdb55bb0_0 
  packaging                            23.1-py311hecd8cb5_0 --> 23.2-py311hecd8cb5_0 
  panel                               1.3.8-py311hecd8cb5_0 --> 1.4.1-py311hecd8cb5_0 
  param                               2.0.2-py311hecd8cb5_0 --> 2.1.0-py311hecd8cb5_0 
  plotly                              5.9.0-py311hecd8cb5_0 --> 5.19.0-py311h85bffb1_0 
  pycodestyle                        2.10.0-py311hecd8cb5_0 --> 2.11.1-py311hecd8cb5_0 
  pydantic                          1.10.12-py311h6c40b1e_1 --> 2.5.3-py311hecd8cb5_0 
  pyflakes                            3.0.1-py311hecd8cb5_0 --> 3.2.0-py311hecd8cb5_0 
  pylint-venv                         2.3.0-py311hecd8cb5_0 --> 3.0.3-py311hecd8cb5_0 
  pyobjc-core                           9.0-py311h9205ec4_1 --> 10.1-py311h46256e1_0 
  pyobjc-framework-~                    9.0-py311h9205ec4_0 --> 10.1-py311h9205ec4_0 
  pyobjc-framework-~                    9.0-py311h46256e1_0 --> 10.1-py311h46256e1_0 
  pyobjc-framework-~                    9.0-py311hecd8cb5_0 --> 10.1-py311hecd8cb5_0 
  python-lsp-black                    1.2.1-py311hecd8cb5_0 --> 2.0.0-py311hecd8cb5_0 
  python-lsp-jsonrpc                     1.0.0-pyhd3eb1b0_0 --> 1.1.2-pyhd3eb1b0_0 
  python-lsp-server                   1.7.2-py311hecd8cb5_0 --> 1.10.0-py311hecd8cb5_0 
  pyviz_comms                         3.0.0-py311hecd8cb5_0 --> 3.0.2-py311hecd8cb5_0 
  qdarkstyle                             3.0.2-pyhd3eb1b0_0 --> 3.2.3-pyhd3eb1b0_0 
  qtconsole                           5.4.2-py311hecd8cb5_0 --> 5.5.1-py311hecd8cb5_0 
  rope                                1.7.0-py311hecd8cb5_0 --> 1.12.0-py311hecd8cb5_0 
  scipy                              1.11.4-py311h7695dc5_0 --> 1.12.0-py311h7695dc5_0 
  scrapy                              2.8.0-py311hecd8cb5_0 --> 2.11.1-py311hecd8cb5_0 
  semver             pkgs/main/noarch::semver-2.13.0-pyhd3~ --> pkgs/main/osx-64::semver-3.0.2-py311hecd8cb5_0 
  spyder                              5.4.3-py311hecd8cb5_1 --> 5.5.1-py311hecd8cb5_0 
  spyder-kernels                      2.4.4-py311hecd8cb5_0 --> 2.5.0-py311hecd8cb5_0 
  tzdata                                   2023d-h04d1e81_0 --> 2024a-h04d1e81_0 
  widgetsnbextension                  3.5.2-py311hecd8cb5_1 --> 4.0.10-py311hecd8cb5_0 
  xz                                       5.4.5-h6c40b1e_0 --> 5.4.6-h6c40b1e_0 
  yapf               pkgs/main/noarch::yapf-0.31.0-pyhd3eb~ --> pkgs/main/osx-64::yapf-0.40.2-py311hecd8cb5_0 

The following packages will be DOWNGRADED:

  pydeck                              0.8.0-py311hecd8cb5_2 --> 0.7.1-py311hecd8cb5_0 
  streamlit                          1.30.0-py311hecd8cb5_0 --> 1.16.0-py311hecd8cb5_0 


Proceed ([y]/n)? y


Downloading and Extracting Packages:
                                                                                
Preparing transaction: done                                                     
Verifying transaction: done                                                     
Executing transaction: done            

如果发生错误,再输入一次,即可解决