前端项目运行常见问题

/ 默认分类 / 没有评论 / 2151浏览

npm install时 node-sass npm ERR command failed问题解决

查找对应node版本

可能是node.js的版本和node-sass的版本不合,下一个符合node-sass版本的node.js

查看需要的node-sass的版本 在package.json文件中找到node-sass": "^版本号",记下版本号

https://nodejs.org/zh-cn/download/releases/

根据node-sass的版本找到合适的node.js版本下载

npm官网 https://www.npmjs.com/package/node-sass

NodeJSSupported node-sass versionNode Module
Node 198.0+111
Node 188.0+108
Node 177.0+, <8.0102
Node 166.0+93
Node 155.0+, <7.088
Node 144.14+83
Node 134.13+, <5.079
Node 124.12+, <8.072
Node 114.10+, <5.067
Node 104.9+, <6.064
Node 84.5.3+, <5.057
Node <8<5.0<57

比如说node-sass是4.9.3就找node10,node module是64的

卸掉之前装的node-sass

npm uninstall node-sass

安装指定版本的node-sass

npm install node-sass@指定的版本号

找不到node_modules/node-sass/vendor模块的解决办法

Error: ENOENT: no such file or directory, scandir ‘…/node_modules/node-sass/vendor’

这个错误的意思就是找不到node_modules/node-sass/vendor模块。

npm rebuild node-sass

npm 安装 chromedriver 失败的解决办法

切网络