Unsupported major.minor version 52.0解决办法

/ 默认分类 / 没有评论 / 154浏览

1.首先解释一下报错原因:

stanford parser和jdk版本对应关系

J2SE 8 = 52,
J2SE 7 = 51,
J2SE 6.0 = 50,
J2SE 5.0 = 49,
JDK 1.4 = 48,
JDK 1.3 = 47,
JDK 1.2 = 46,
JDK 1.1 = 45

Unsupported major.minor version 52.0: 看到Unsupported你是不是会想到jdk高版本能兼容低版本,但是低版本不能兼容高版本,不错,猜对了,其实就是这个意思。这个错误意思是你项目用JDK1.8运行过,现在又在本地的eclipse等开发工具或者本地环境变量为低版本的jdk1.7或者jdk1.6下运行,eclipse会说:“抱歉,我本地jdk版本太低,不支持这个高级版本jdk1.8编译过的项目运行”。

你看看你本地是报52还是51或者其他的错。

2.配置jdk解决问题:

这几个地方jdk要一致:

  1. 看看你系统的jdk环境变量配置的是jdk那个版本

  2. Windows—— Preferences——Java——Compiler——设为jdk1.8

  3. 在此页面的Java——Installed JREs——设为jdk1.8

  4. 关闭此页面,项目右键(或者core包)——Build Path(也可是Properties)——Configure Build Path——Java Build Path——Libraries下面的JRE System Library改为jdk1.8(此处设置见参考3),保证旁边的Order and Export这个jdk与之相同

  5. 同页面的Java Compiler选项改为jdk1.8

  6. 同页面的Project Facets——右侧的Java改为1.8(此项也可以不改)

  7. 如果还不行看看你的Eclipse的Server里配置的tomcat和jdk版本是否不同:

Windows——Preference——Server——Runtime Environments——点击你要用的tomcat——点击Edit ——在弹出面板的JRE中选择和你项目对应的jdk版本

  1. 如果上述还不管用的话试试:

修改org.eclipse.wst.common.project.facet.core.xml: 打开项目所在的文件夹,打开.settings文件夹,修改里面的“org.eclipse.wst.common.project.facet.core.xml”文件

如我的路径是:D:\cctv5cms\maven.1490956540309\cms-cms\cms-core.settings\org.eclipse.wst.common.project.facet.core.xml

本文链接:http://blog.csdn.net/superit401/article/details/72731381

参考1:https://www.zifangsky.cn/600.html

参考2:http://bbs.csdn.net/topics/391873068

参考3:http://www.oschina.net/question/207494_84715